Une grosse avancée de Linux 4.11 sur les puces Intel Atom Bay Trail et Cherry Trail

Frustration, c’est le terme qui décrit parfois l’état d’humeur d’un propriétaire d’un MiniPC sous Intel Atom face à une distribution Linux. La mise à jour vers le Kernel Linux 4.11 devrait régler pas mal des soucis actuels.

Et pourtant les systèmes Linux conviennent comme un gant à ces MiniPC aux performances pas forcément incroyables. Si ils fonctionnent bien sous Windows avec 2 Go de mémoire vive, ils sont très impressionnants sous Linux Mint ou Ubuntu avec la même quantité de mémoire vive. Or, toute une génération de minimachines sous Atom Bay trail est sortie avec 2 Go de mémoire vive et 32 Go de stockage seulement.

Minimachines.net

L’arrivée de Linux 4.11 va solutionner pas mal de soucis variés et apporter des avancées sur bien des points. Mais dans le petit monde des minimachines, c’est surtout un petit détail qui va changer la donne. Les engins sous Atom Bay Trail et Cherry Trail pâtissent en effet d’un défaut récurrent, celui d’une incompatibilité des systèmes Linux actuels avec leur gestion de l’HDMI audio.

La solution alternative est simple évidemment, pour ma part j’utilise un DAC USB pour brancher ces MiniPC sur une chaîne Hifi tandis que le signal vidéo transite vers un téléviseur. Mais ce serait tout de même plus simple d’employer l’HDMI audio directement. Avec Linux 4.11, ce sera désormais possible et ainsi Ubuntu 17.10 devrait proposer cette fonction de base. Les autres distributions qui suivront le rythme de l’évolution Linux devraient également profiter de cette mise à jour rapidement.

Minix Neo Z64

Un des nombreux MiniPC sous Atom Bay Trail

Le bloggueur et développeur Ian Morrisson indique la marche à suivre pour profiter de cette avancée dès aujourd’hui en lançant un script permettant de générer une image d’Ubuntu soi même avec le dernier Kernel 4.11. Le même Ian Morrisson propose en outre de corriger pas mal de petits problèmes de compatibilité entre Linux et les machines low-cost sous Atom à l’aide d’autres scripts. La prise en compte du Wifi  et du Bluetooth par exemple. Son blog est une adresse à retenir et à mettre en favoris si vous avez une solution “Trail” sous Linux.

Source : Liliputing

29 commentaires sur ce sujet.
  • 30 mars 2017 - 10 h 45 min

    4.11? o0 il tape dans kernel.org pour l’avoir chez moi (Debian) la 4.10 est même pas encore sortie d’experimental alors la 4.11 c’est pas pour tout de suite

    Répondre
  • 30 mars 2017 - 10 h 47 min

    PS: t’a un serieux problème de cache coté serveur : les commentaires visibles sur la page d’accueil ne sont pas visibles dans leurs articles respictifs avant un bon moment, et pour pouvoir lire cet article j’ai dû suivre le lien twitter

    Répondre
  • 30 mars 2017 - 11 h 17 min

    ‘LLo,

    Il est déjà en 4.11rc2 (expérimental) sur une “roulante” au nom africain aussi (mais en abrégé)..! ;-)

    Répondre
  • 30 mars 2017 - 12 h 22 min

    J’ai lu quelque part que Debian/Stretch était retardée pour attendre le 4.10 qui sera une version avec un support long. Alors la 4.11 chez Debian, pas avant 3 ans ;)

    Répondre
  • 30 mars 2017 - 13 h 43 min
  • 30 mars 2017 - 14 h 26 min

    C’est enfin une bonne chose de dénoncer que Linux n’apportait de nombreux soucis !

    Si on écoutait certains depuis des années, Linux ça fonctionne super ! (Dans leurs rêves peut-être surement, mais pas dans la réalité !)

    Répondre
  • 30 mars 2017 - 14 h 35 min

    @sopilou: Linux est gratuit, fonctionne sur la base du développement de passionnés non rémunéré. Le travail effectué est remarquable et si les marques/constructeurs/développeurs communiquaient mieux ce serait probablement encore plus simple.

    Logique qu’il y ait des soucis de développement. Maintenant on parle ici de soucis relativement mineurs…

    Répondre
  • 30 mars 2017 - 14 h 35 min

    Excellent nouveau, je pense que mon EeeBook X206 appréciera et ca lui donnera un coup de pouce bien mérité.

    Répondre
  • 30 mars 2017 - 15 h 58 min

    @sopilou:

    Linux ça fonctionne super bien. Personne n’a dit que c’était le cas partout, tout le temps.

    Mais en effet, c’est toujours bien de basher un projet ouvert à tous, apportant moult bénéfices à tous, et porté par des bénévoles.

    Répondre
  • 30 mars 2017 - 17 h 21 min

    @sopilou:

    Il faut sélectionner un peu son matos, parfois… et si on prends des trucs à emmerdes/tous neufs, il y a un risque à assumer.

    Pour le reste, je n’utilises quasiment plus que cela. Et c’est pas ce tas de boue de Win10 qui va me faire changer d’avis.

    Pour le reste, Linux=Boite blanche ou chacun peu contribuer: Si WinIntel voit un marché côté grand public ils se sortiront les doigts du c.. niveau support de leur matos. C’est déjà le cas, mais surtout sur les processeurs serveurs: Là, ils n’ont plus le choix depuis longtemps!

    Répondre
  • 30 mars 2017 - 18 h 03 min

    @?
    bah, le 4.10, on peut deja l’avoir facilement
    même sur ubuntu au pire
    http://cubuntu.fr/?q=node/25
    pas ma distro respin favorite, mais il y a “tout” donc pas mal pour beaucoup

    l’avantage du 4.10, le support de ryzen par exemple (ultimate prépare “sa” version aussi que j’attends plus chez “ubuntu”) et des derniers intel par exemple

    donc le 4.11, ça devrait pas tarder à être pour tous (si on le souhaite)

    sinon, cool effectivement pour ceux qui ont des intel en box
    les belkin et compagnies, beaucoup s’arrachent les cheveux pour linux (faut dire que rien n’est standard là dedans, c’est fait n’importe comment apparemment. enfin, chacun à sa sauce quoi)
    même si généralement, c’était pris pour faire du serveur fanless pas cher donc bon

    en tous cas, pour les baytrail, j’avais mis (après avoir cherché et testé loongtemp), une LMDE (linux mint DEBIAN edition)
    et tous roulait deja nikel
    une nouvelle iso vient de sortir d’ailleurs (moins de mise à jour à faire du coup)

    le seul “hic” que j’avais sur ce pc (un netbook), c’était les pilotes graphiques qui ne permettaient pas de faire un vrai clone de l’ecran
    obligatoirement un mode “étendu” (perso je trouvais ça dommage mais ça n’a pas dérangé la personne qui l’a maintenant)
    sinon, c’était deja très bien

    vu les avancées, le futur semble bon (enfin !) pour ces petites machines sous linux (même si je leur préfère les versions pentium…mais pas au même prix)

    le hic semble quand même surtout venir des fabricants “low cost” (principalement) qui ne font pas du “standard” et du coup, ça marche mal avec les atoms

    Répondre
  • 30 mars 2017 - 18 h 36 min

    Il y a quelques chose que j’ai loupé ? Sous Linux Mint 18.1 Cinnamon, je suis en kernel 4.4.0 …

    Répondre
  • 30 mars 2017 - 20 h 48 min

    Bonjour Pierre
    Tu crois que ça peut fonctionner correctement sur un media akoya (clone du msi wind) ?

    Répondre
  • 30 mars 2017 - 21 h 28 min

    @laurent221: En fait ce n’est pas un Atom Cherry / Bay Trail dans l’akoya. cela dit l’akoya n’a pas de soucis avec Linux à ma connaissance ? Essaye un Mint :)

    Répondre
  • 30 mars 2017 - 21 h 32 min

    @tofeur: Mint est basée sur Ubuntu LTS, qui propose un kernel 4.4.0. Le 4.8.0 est proposé en option depuis la dernière révision (16.04.2), mais aucune idée si Mint compte également le proposer. Dans tous les cas, ce n’est pas le genre de distro à faire la course à la dernière version.

    Par contre, sous Arch Linux on a bien le dernier 4.10.6. Fedora 25 propose également le 4.10.5 depuis une récente mise à jour.

    Maintenant, si tu en a réellement besoin, il existe toujours des packages non officiels, https://mintguide.org/system/737-install-linux-kernel-4-10-stable-on-linux-mint.html

    Répondre
  • 30 mars 2017 - 21 h 57 min

    @Okki: Merci Okki !

    Répondre
  • 31 mars 2017 - 6 h 20 min
  • 31 mars 2017 - 10 h 36 min

    en fait, pour la majorité des gens, les version LTS des noyaux suffisent et pas la peindre de prendre autre chose (debian stable inclue dans ce raisonnement)

    le “but” de faire un kernel upgrade, c’est generalement parce que les drivers sont DANS le kernel
    donc si votre matos est “nouveau” et que vous voulez en profitez avec votre distribution favorite, avoir le kernel ou vous êtes sur d’avoir les optimisations pour celui ci est intéressant
    sinon, à par ceux qui veulent avoir le der du der…
    je critique pas, mais je n’en vois plus l’utilité (d’où mon penchant pour debian et non arch)

    comme dit au dessus, c’est par exemple le support du amd ryzen avec le 4.10 ou une meilleure gestion des profils de batteries et de gestion d’énergie pour les portables etc etc
    bien sur, ceci ne concerne QUE les pilotes libres (donc DANS le noyau), pas les proprio à rajouter ensuite (comme les wifi broadcom ou nvidia amd pour carte graphique)

    ceci dit, et comme posté un peu partout ici, même sur une ubuntu (ou mint, ce qui revient au même), on peut garder sa version lts et passer à un noyau plus récent
    rien n’est réellement figé (juste bien savoir ce qu’on fait)

    ici, les possesseurs de solutions atoms “trayl” ayant des soucis avec leurs solutions trouveront une solution simple à leurs soucis (si tant est que le fabricant de leur box ait fait un minimum dans les standards de l’industrie)
    et une iso “tout faite” pour ces personnes est un bon point (tout le monde ne sait pas faire)

    bonne fin de journée à tous
    (et moi j’y retourne, vivement le 1 avril, je suis HS avec tous ça)
    bye

    Répondre
  • 4 avril 2017 - 16 h 07 min
  • 6 avril 2017 - 12 h 48 min

    Tiens, Mint 18.1 propose maintenant le noyau 4.10.0-14 sans bidouille.

    Répondre
  • 6 avril 2017 - 13 h 36 min

    @tofeur: mint bosse beaucoup avec logic supply qui fait les mint box
    elles sont generalement en amd et une nouvelle génération de proc amd vient de sortir
    le 4.10 apporte le support de ces proc (et de certains intel aussi)

    je sais que le “patron” de mint a fait une petite visite chez eux il y a peu (et adore leurs machines)
    peut être un upgrade des mintbox ou de nouveaux prod

    mint est LE linux vendu chez logic supply
    (et les dernieres plateformes AMD sont top, j’attend avec impatience les cartes meres mini itx pour ryzen)

    Répondre
  • 20 mai 2017 - 9 h 46 min

    Est-ce que les nouveautés seront ajoutées au noyau 4.9 par après ?

    Répondre
  • 6 septembre 2018 - 12 h 37 min

    @laurent221: J’utilise Linux Mint 17.3 + RemixOS sur mon Medion Akoya Mini (clone MSI Wind U100)

    Répondre
  • 6 septembre 2018 - 14 h 19 min

    @oursgentil: Merci pour le retour, une idéée de lien pour un tuto car mes connaissances unix remontent aux années 90…

    Répondre
  • 6 septembre 2018 - 16 h 53 min

    @laurent221: Sur l’installation de linux mint ou de Remix OS ?

    Répondre
  • 23 septembre 2018 - 0 h 47 min

    @oursgentil: sur mint 17.3 quelle version prendre ? je viens d’essayer la 19 et le wifi ne fonctionne pas

    Répondre
  • 23 septembre 2018 - 9 h 00 min

    @laurent221: Je te conseille une Mint 17.3 car :
    * au dela, une definition mini de 1024×768 est demandée à partir de la version 18 (or les netbooks sont limités à du 1024×600)
    * Et la version 19 demande 2 Go de ram (version 17/18 demandent que 1 Go)
    * Une version 32 bits car l’atom n270 est un cpu 32 bits
    * une version XFCE car l’atom N270 est vraiment limité (270 points sur le sitte passmark)

    https://linuxmint.com/edition.php?id=213

    Ensuite, je sais qu’il y a un difference de carte Wifi entre le MSI Wind U100 et Le medion Akoya mini

    https://en.wikipedia.org/wiki/MSI_Wind_Netbook
    => Wifi b/g sur MSI WInd U100
    => Wifi b/g/n sur Medion Akoya Mini

    Je crois que le MSI WInd a été assemblé avec plusieures carte Wifi

    dans un terminal tape les commande lspci -v

    Répondre
  • 23 septembre 2018 - 9 h 01 min

    @laurent221: je sais pas si mon post est passé. Dis moi si tu vois mon “gros” post

    Répondre
  • 23 septembre 2018 - 9 h 53 min

    @laurent221:
    Je recommence

    Je te conseille la version 17.3 XFCE car :
    * les version 18 et 19 demandent un affichage mini en 1024×768. Or le msi est limité à 1024×600
    * la version 19 demande 2 go de ram
    * la version 32 bits car l’atom N270 n’est pas 64 bits
    * la version XFCE car l’atom est tres limité (270 poits sur le site passmark)

    donc celle-ci : https://linuxmint.com/edition.php?id=213

    Enfin, pour le Wifi, il ya un ecart entre le mSI wind et l’akoya mini (wifi b/g sur le wind et wifi b/g/n sur l’akoya mini)
    https://en.wikipedia.org/wiki/MSI_Wind_Netbook

    En plus, sur le MSI Wind U100, il semble qu’il y ait eu plusieurs fournisseurs de carte

    Sous Linux, ouvre un terminal et tape la commande lspci -v

    Cela te devrait te permettre de savoir excatement quelle est ta carte wifi

    Et sinon, quel devrait etre l’utilisation de ce netbook ? (je suis en train de monter un micro pc passif sous Linux Mint, je peux te donner quelques conseils d’optimisation)

    Répondre
  • LAISSER UN COMMENTAIRE

    *

    *